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options." 

2. Click the View tab. 

3. In Advanced Settings, scroll down and check the box next to "Use check 
boxes to select items." Click OK. 

4. From now on, when you hover your mouse over a file in Windows 

Explorer, a check box will appear next to it; click it to select the file. Once a 

file is selected, the checked box remains next to it; if you uncheck it, the box 

will disappear when you move your mouse away. 

View Pictures Full Screen 

When you need a really big window for viewing photos and videos, don't just 
maximize it: go full screen! This tip works great for viewing photos and videos 
at maximum size in Windows Explorer or Windows Media Player, utilizing 
screen space usually occupied by the header at the top of the screen and the 
taskbar at the bottom. Here’s how: 

Open any photo in Windows Explorer, or open a photo or video clip in 
Windows Media Player. Do one of the following: 

In Windows 7 and Windows XP, click the F11 key at the top of your 
keyboard. 

The photo or video image enlarges to its maximum size and the title bar and 
taskbar are hidden. 

To undo full-screen mode and restore the window to its normal view, press 

the Esc (Escape) key at the top of your keyboard . 
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Wrapping Text Around Images in Microsoft Word 
2010 

Wrapping text around the shape of images inserted into Microsoft Word 2010 
is easy if you follow these simple steps. 

After you have inserted your image, make sure that the image is still 
selected. Then, go to the ribbon at the top of the screen and click the Format 
tab under Picture Tools. In the Arrange section you should see the Wrap 
Text button. Click the button and choose the desired option from the 
available text wrap styles, such as: In Line with Text, Square, Top and 
Bottom, Behind Text and more. 

If you would like a more customized text wrap for your image, try clicking the 

option for Edit Wrap Points, which will be available after you have applied 

one of the general text wrap styles. Edit Wrap Points allows you to 

manipulate the frame that the program uses to determine the shape and 

boundary of the text wrap. Change the shape and dimensions of the 

wrapped area by clicking and dragging the points of the frame. 

Add a Videos Link to the Start Menu 

The Windows 7 Start Menu includes links to your Pictures and Music folders, 
but not to your Videos folder. If you watch a lot of videos and want a link to 
them on your Start Menu, here's what you can do: 

1. Right-click the Start button and select Properties. 

2. On the screen that appears, go to the Start Menu tab and click Customize. 

3. In the dialog box that appears, scroll to the bottom, look for the Videos 

section, select "Display as a link," and click OK and then OK again. 

Use check boxes to select multiple files 

In order to select multiple files for an operation such as copying, moving or 
deleting in Windows Explorer, you generally use the keyboard and the 
mouse, Ctrl-clicking every file you want to select. But if you're mouse-centric, 
there's a way to select multiple files in Windows 7 using only your mouse, via 
check boxes. To do it: 

1. In Windows Explorer, click Organize, and then select "Folder and search 
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Keyboard shortcuts everyone should know 

Ctrl + C or Ctrl + Insert 

Copy the highlighted text or selected item. 

Ctrl + V or Shift + Insert 

Paste the text or object that's in the clipboard. 

Ctrl + Z and Ctrl + Y 

Undo any change. For example, if you cut text, pressing this 
will undo it. This can also often be pressed multiple times to 
undo multiple changes. Pressing Ctrl + Y would redo the undo. 

Ctrl + F 

Open the Find in any program. This includes your Internet 
browser to find text on the current page. 

Alt + Tab or Alt + Esc 

Quickly switch between open programs moving forward. 

Tip: Press Ctrl + Tab to switch between tabs in a program. 

Tip: Adding the Shift key to Alt + Tab or Ctrl + Tab will move backwards. For 
example, if you are pressing Alt + Tab and pass the program you want to 
switch to, press Alt + Shift + Tab to move backwards to that program. 

Tip: Windows Vista and 7 users can also press the Windows Key + Tab to 
switch through open programs in a full screenshot of the Window. 

Tip: Windows Key + D minimises open windows and takes you to the 
Desktop. Windows Key +D again and the minimised windows will reopen at 
the same place they were before minimising. 

Tip: Windows Key + E opens the Windows Explorer program showing all the 

drives on your computer. 
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Using Picasa to make a Face Movie 

Face MoviCtrle analyzes the faces in your selected photos to find the 
smoothest transitions across facial expressions and poses. Unlike a movie 
presentation, Face Movie overlays the most similar facial expressions in 
each photo on top of each other to create the smoothest transitions. To 
create a Face Movie in Picasa, follow these steps: 

1. Select multiple photos or an entire People album. 

2. Click Create/Video/From Faces in selection. 

3. You can select different transitions from the 'Transition Style' 
drop-down menu, choose the slide duration, or even the 
amount of overlap across photos. 

4. Click Create Movie. 
Your drafts and finished masterpieces will be saved in your 'My Pictures' 

folder 

W8 Quick access menu 

Right-click in the bottom left corner of the screen  
or  
Hold down the Windows key and press X 

You will get a text-based menu that provides easy access to lots of useful 

applets and features including: Device Manager, Control Panel, Explorer, the 

Search dialog, Command prompt, Task Manager and more. 

  

Copy Paragraph Formatting From One Place to Another in Word 

Often it is beneficial to copy paragraph formatting from one place in your 
document to another. Word provides a quick way you can do this by using 
the mouse: 

1. Select the paragraph whose formatting you want to copy. 

2. Click on the Format Painter tool on the toolbar (it looks 

like a paintbrush). 

3. Using the mouse, select the paragraph you want 

formatted. 
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 Desktop Printing to compresses the pictures to 220 ppi 

 Web to compress the pictures to 96 ppi 

 Under Apply compression settings now, choose whether you want to 
compress all pictures in the publication or only the pictures that you 
selected, and then click OK. 

 If a message appears asking whether you want to apply picture 
optimization, click Yes. 

 A compressed version of the same picture or pictures replaces the 
original high-resolution picture or pictures. 

Single Click Instead of Double Click 

Having trouble Double clicking? It is possible to set your computer so that a 
single click will open items... 

Here's how to do it: 

1. First, load up Windows Explorer by pressing WINDOWS KEY + E, or by 
clicking Computer on your start menu. 

2. Next, click Organize > Folder and Search Options. 

3. After the folder options window appears, simply select "Single click to 
open an item" and then click OK. 

That's it! Now you only need to click an icon once to open any application. 

Add a Shortcut to the Send To menu 

To add your own shortcut to the Send To menu, load the run box (by 
pressing WINDOWS KEY + R) and enter the following command and then 
click OK: 

%APPDATA%\\Microsoft\\Windows\\SendTo 
(You could copy the text above and paste it into the command box) 

This opens the Send To folder in your Windows Explorer. Now Right click in 
the white space on the right, and select New > Shortcut. 

Navigate to the location of the application you wish to add and click Next. 

Now, enter the name you want to appear on the Send To menu and then 
click Finish. 
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Or, you can nudge all objects simultaneously. Click outside all objects to 

make sure none are selected. Press Ctrl + A to select all objects, and then 

nudge them all at once. 

Making smaller Publisher files 

In Publisher, you can reduce the resolution of one, several, or all pictures by 
compressing them. 

 In Publisher, select one or more pictures whose resolution you want to 
reduce 

 Right-click one of the selected pictures 

 Click Format Picture on the shortcut menu, and then click the Picture tab 

 Click the Compress button 

 
 In the Compress Pictures dialog box, under Target Output, choose of the 

offerings:  

 Commercial printing compresses pictures to 300 pixels per inch (ppi) 
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You can also copy the same format repeatedly by double clicking the Format 

Painter tool in step 2. You will then be able to apply the same formatting until 

you turn off format painting by clicking on the tool one more time or by 

pressing Esc. 

Creating Page Footers and Headers in Word 

Word allows you to add headers and footers to your document. 

Headers are nothing more than repeating text that appears at the top of 
every page of your printed document, whereas footers appear at the bottom 
of each page. 

The beauty of headers and footers is that they only have to be defined once, 
and then Word places them on your printed pages automatically. 

The easiest way to create a header or footer in Word is to simply double-click 
at the top or bottom of a page, where the header or footer will appear. 

You can also, if you prefer, follow these steps: Display the Insert tab of the 
ribbon. 

 Click the Header tool in the Header & Footer group, and then click Edit 
Header. 

 The header is displayed and the insertion point is within it. If desired, 
enter the information for the header, formatting it as you would format 
normal text in your document. 

 Click on the Go To Footer tool on the Design tab of the ribbon. 

 If desired, enter the information for the footer, formatting it as you would 
format normal text in your document. 

Click on Close Header and Footer (on the Design tab of the ribbon) when 

your header and footer are defined the way you want them. 

Windows 7 Themes – try some different ones 

Do you like to see great backgrounds pictures (wallpapers) on the desktop? 
There are probably many themes available on your computer for you to use 
now 

If you use Windows 7 then try this – we will be using the Windows key in 
these instructions, it’s the one with the Windows logo on it, on most 
computers it’s near the Space bar 

 tap the Windows key 

 immediately type the word theme – notice that Change the theme 
appears at the top of the list above and is selected 

 while Change the theme is still selected; tap the Enter key 
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 notice that the window that opens is showing the themes that are on your 
computer now 

 click a one of the themes and it will become the new one 

 the next few instructions will make these instructions disappear – maybe 
you can print them out 

 hold the Windows key down and tap D – your desktop appears and you 
can see a new wallpaper 

 right click on the desktop (not an an icon) then tap V then Enter and then 
D – the icons disappear and you have a better view of the wallpaper 

 hold down the N key and then tap the right mouse button – see the next 
wallpaper 

 still holding down the N key, tap the right mouse button again – the next 
wallpaper appears 

 good fun eh? You can keep tapping N to cycle through all the wallpapers 

 to get your icons back just do the 3 key trick again - right click on the 
desktop and then tap V and D 

 Windows D will bring back the instructions 

 do it all again to check out the other themes 
There are hundreds of themes available to download – this will be the subject 
of another tip 

Moving pages around in a multi-page Publisher document 

Here are two ways to move pages around: 

1.  Cl ick  and hold the mouse but ton down on a page 
number near  the bottom of  the Publ isher window, 
then re lease the page before or af ter  the page 
where you wish to move the current  content .  
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Using Tabs when browsing the Internet 

When you are using Google to find websites it can be a pain clicking on a 
site and then having to go back to the search results to look for another site. 

If you hold down the Ctrl key as you click a site then that site will open in a 
new tab. The new tab will appear beside the address bar of the browser. 

You can keep doing the Ctrl click action to open many new tabs. 

Now you can click on each of the tabs and inspect the sites you selected 

earlier. 

Using Internet search engines to their full potential 

Make sure to get the most out of every search result. If you're not finding 
what you want try surrounding the text in quotes. 

For example, if you were searching for computer help this actually searches 
for pages that contain both computer and help and not necessarily pages 
that have computer and help next to each other. 

If you search for "computer help" with the quotes around the search query 
this will only return pages that actually have computer and help next to each 
other. 

Tip: Many new computer users also don't realize that in every search box 

you can simply press the enter key instead of having to move the mouse 

pointer over to the Search button. 

More precise positioning in Publisher 

Sometimes in Publisher you may need to slightly move objects to the left, 
right, up, or down with greater precision than what can be had by clicking and 
dragging with the mouse. Let's nudge an object pixel by pixel. 

First click on the object (say a picture or text box) to select it, now hold down 
the Alt key and tap any of the cursor keys (up, down, left or right) and the 
selected object will be moved a little bit (nudged). 

This works even on a text box that you are currently editing. You can even 
hold down the Ctrl key and select multiple objects, then press Alt and the 
cursor keys to nudge multiple boxes. 
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group, click the size of the text you want. After you click the text size you 

want, the Ribbon goes back to being minimized.  

Use 3D Flip to Preview Running Programs 

Have you noticed the Widows key? It's usually near the space bar on your 
keyboard. It has the Widows logo on it. 

In Windows 7, if you have a number of applications running, you can use this 
key to scroll through them. Here's how: 

Hold down the Windows key and tap the Tab key. 

Keep holding the Windows key and use the Tab key to scroll through the 
running programs. 

When you release the Windows key the frontmost program will appear. 

Visiting Web Addresses Found in an Email 

Have you ever gotten email that contained web addresses that you wanted 
to visit? Depending on the email and the software that you use to read your 
email, you may have just been able to simply click on a link and get taken to 
the website mentioned in the mail. If this does not work for you, don't fret. 
You do not have to retype the web address mentioned in the email into your 
web browser. 

In your email, select the desired web address with your mouse by clicking on 
the first character of the web address, keeping your mouse button held 
down, then dragging to the end of the web address. The web address will 
become highlighted showing you that it is selected 

Now hold down the Ctrl key and tap the C key (this copies the address to the 
clipboard). 

Open up your favorite web browser, click in the "Address box" any text there 
will become selected. Again hold down the Ctrl key and this time tap the V 
key (this pastes the clipboard contents to the address bar. 
 
  

Finally, press ENTER and the website will appear! Practice this a few times 

and you will find this far easier than typing the web address into your 

browser. 
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2. Click the "Edit" dropdown menu and choose "Move Page" 

 

A "Move Page" dialog box appears. 
 

 

Click a radio button to determine whether to move the current page before or 
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after a desired page, and then select the page where you wish to move the 
current page before or after. Click "OK" on the dialog box to finalize the 
move. 

Get Publisher to quickly fit overflow text inside the text box 

Instead of adjusting and readjusting text, Publisher has a feature that can 
automatically resize text to fit inside its box. You can force text to fit inside 
the current text box size or mark a text box so that whenever it is resized, the 
text size automatically adjusts for a best fit. 

 

Text box in Publisher that contains overflow text and the same text after 
autofitting 

In Publisher 2007: 

1. Click inside a text box that contains overflow text. 

2. Select "Format" - "AutoFit Text". 

3. Select one of the three options: 

* (default) Do Not Autofit - Do not automatically adjust the text size. 

* Best Fit - When you resize the text box, this automatically adjusts the font 
size so the text fits inside the box. 

* Shrink Text on Overflow - Shrinks the text inside the box if there is any 
overflow text. 

It's even simpler in Publisher 2010: 

Right click inside a text box that contains overflow text and select Best Fit. 

A quick way to create a table in MS Word 

You can use the plus and minus keys to easily produce a table 

19 

 

Many ways to underline text in Publisher 

It's easy to underline text in Microsoft Publisher documents - select the text 
and tap the underline button in the toolbar or press Ctrl / U. 

But what if that isn't enough to draw attention to the text and you want to 
double-underline it? 

And the options in Publisher don't stop there - you can perform other types of 
underlines: 

 

1. Highlight the word or words you want to underline. 

2. Select "Format" - "Font" or right-click and choose "Change Text" - "Font". 

3. The "Font" dialog box appears. Underneath "Underline", choose your 
desired underline style. Sample text will appear below in the "Sample" box. 

4. Click "OK" to close the dialog box. 

  

Minimise the Ribbon in Office 2007 or 2010 

Method 1: use Ctrl/F1 (hold the Ctrl key and tap the F1 (near the Esc key). 
Using Ctrl/F1 again restores the ribbon 

Method 2: double click the name of the active tab. Double-click a tab again to 
restore the Ribbon. 

To use the Ribbon while it is minimized, click the tab you want to use, and 
then click the option or command you want to use. 

For example, with the Ribbon minimized, you can select text in your 

Microsoft Office Word document, click the Home tab, and then in the Font 
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Make text 'Glow' in Microsoft PowerPoint 2007 

 With a few clicks you can make text glow in a variety of colors. 

1. Highlight the text that you want to glow. 

2. Click the "Format" tab in the Ribbon. 

3. Click on the "Text Effects" pull-down, selecting "Glow". 

4. Choose your desired glow variation (color and size of glow). Or, click on 
"More Glow Colors" to choose from more colors, and then you can click 
"More Colors" to choose from even more colors. 
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to your specifications. 

Start Word and in your document just type the sequence below 
and then tap the Enter key 

+------------------------+-----------------------+------+-----------------------+ 

Voila! There’s your table 

 

When your cursor is in the rightmost column tap the Tab key to 

add another row. 

Starting Internet Explorer in Private Mode 

You can start Internet Explorer in the InPrivate mode which doesn't save 
your personal information (such as: browser history and cache files for 
personal privacy reasons). 

Here's how to create a shortcut that enables this feature when you launch its 
icon: 

 Right-click an empty space on the desktop and click New, then select 
Shortcut. 

 Type the following information into the Location field when wizard 
displays: "%ProgramFiles%\Internet Explorer\iexplore.exe" -private 

 Press the Next button, give the shortcut a name (for example "IE Private 
mode"). 

Press the Finish button when done. 

Sending or Forwarding Joke emails 

1. Always give your e-mails subject lines so that recipients can decide 
whether or not they need the message. You may want to consider starting 
subject lines with the word JOKE: or similar to let busy individuals know the e
-mails aren't urgent. 

2. DO NOT WRITE YOUR JOKES IN ALL CAPS! Many people consider 
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such e-mails as "shouting". Again, send too many of these e-mails and you'll 
start getting ignored. 

3. When sending e-mails to a group of people, use your e-mail website or 
software's BCC (blind carbon copy) feature instead of using the CC (carbon 
copy) feature. This hides the recipient addresses from each other. BCC 
increases privacy as some people on your homegrown list would rather not 
have their addresses sent out to possible strangers.  
Note that e-mail can be permanent - just because you delete a message 
doesn't mean it is gone forever. You don't want to be remembered 10 years 
later for sending a tasteless e-mail message! 

5. Never send e-mail attachments without first notifying the recipients that 
files are coming. This is because the "from" address in e-mail messages can 
be easily spoofed. Plus, e-mail accounts can be hacked, allowing nefarious 
individuals to send e-mail, complete with malware-laced attachments, from 
other peoples' accounts without their knowledge. 

6. If a joke has been forwarded multiple times, please remove all of the 
annoying forwarding brackets ">", else the message may become too 
confusing for people to read. Also, if there are any email addresses of other 
recipients in the email, they should be removed. 

7. If a joke or fact sounds too-good-to-be-true, it just might be. Check first to 

see if your e-mail is an urban legend by visiting the Snopes website at http://

snopes.com. 

Clean Up your emails before sending... 

If you receive forwarded emails you will see all the prior recipients of the 
email. 

To clean your forwarded email up before sending it just highlight (the same 

as you do when copying and pasting) the old recipients - then click your 

Right mouse button and select Delete from the menu that pops up. 

Add a Stylish Cover Page in Word 2007 

Add an attractive cover page to your documents. Sometimes your documents 
would benefit from a fancy cover page - Word can help you with this... 

To add a cover page to your document: 

1. Select the "Insert" tab in the Ribbon. 
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even hold down the Ctrl key and select multiple objects, then press Alt and 

the cursor keys to nudge multiple boxes.  

 

Or, you can nudge all objects simultaneously. Click outside all objects to 

make sure none are selected. Press Ctrl + A to select all objects, and then 

nudge them all at once. 

Some Windows key combinations 

The Windows key can usually be found on the bottom row of the keyboard, it 
has the Windows logo on it, this picture should help 

 

Using the Windows key in combination with some other keys causes some 
magic events. You will need to hold down the Windows key and then tap 
another key then release both keys 

Here are a few of the events that you can try now: 

Windows and E – opens the Windows Explorer file manager 
Windows and D – takes you to the Desktop 

W_D again – takes you back to where you were 

W_R – opens the Run box where you can type Windows commands 

W_F – opens the Search (Find) window 

W_L – Locks the computer so others cannot see your files while you are 
away 

W_X – opens the Windows Mobility Center 
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recent publications; and access your templates. 

Maybe you would rather start with a blank slate and design your own 
publication type. Thus, this screen can be disabled or enabled as desired. 

With Publisher 2007 open: 

1. Select "Tools" - "Options". 

2. When the "Options" multi-tabbed dialog box appears, make sure the 
"General" tab is selected. 

3. Check or uncheck "Show Publication Types when starting Publisher" as 
desired. 

4. Click "OK" to close the dialog box. 

In Publisher 2010 click the File menu and choose Options 

Remove the tick from Start the New Template Gallery when starting 

Publisher  

Nudging Objects in Publisher 2007 

 

When designing layouts in Microsoft Publisher 2007, you may often need to 

slightly move objects to the left, right, up, or down with greater precision than 

what can be had by clicking and dragging with the mouse. Normally you can 

click an object and then press the arrow keys to slightly "nudge" it, and you 

can even adjust the distance of object nudging in Publisher 2007 so nudged 

objects move small or large distances. 

 

Nudging is the process of moving objects a little bit at a time in order to line 

up more accurately. 

 

What if you are editing a text box and decide it needs to be nudged? Clicking 

on the box border and then the cursor keys to nudge it isone way but it is not 

so accurate as it moves in bigger increments. 

 

Just hold down the Alt key while pressing cursor keys and any selected 

object will be nudged, even a text box that you are currently editing. You can 
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2. In the "Pages" group, click the "Cover Page" command. 

3. Click on your desired cover page template to add the cover page. 

4. In the cover page, double-click on the fields such as Title and Year to edit 
the appropriate text. 

Word 2010 offers this option too, it's on the Insert ribbon tab. 

 

Turn off Automatic Disk Defragmentation (Vista and Windows 7) 

The Windows defragment feature is always on and it can cause system slow 
down. If you turn it off, just remember to run a defrag manually - say monthly. 

To disable the automatic defragment feature:  

1. Click Start then Computer 
2. Right Click the C: Drive and 

click on Properties 
3. Select the Tools Tab 
4. Click on "Defragment Now" 
5. Uncheck "Run on a schedule" 

if you're using Vista (Windows 
7 users must first click the click 
"Configure Schedule" button 
first) 

Now your PC won't always defrag in the 

background, which should give you some 

more speed. 

Setting Folder Options 

Here's how to customize your folders : 

1. Open the Control Panel and click on the Folder Options icon. 

2. Click on the View tab. 

3. Check or uncheck your folder preferences. Play around with 
them and customize your computer to the way you want it. 



 

10 

 

A few suggestions: 

 Check "Show hidden files and folders" - there's a lot of files and folders 
you can't see until you check this 

 Uncheck "Hide extensions for known file types" - If this is checked, you're 
not seeing the extensions of most files (examples: jpg, gif, doc, txt) 

Uncheck "Hide protected operating system files" - More files that Windows 

keeps hidden from you until you uncheck this. 
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Print the page being viewed. For example, the document in 
Microsoft Word or the web page in your Internet browser. 

Page Up, Space bar, and Page Down 

Pressing either the page up or page down key will move that 
page one page at a time in that direction. When browsing the 
Internet pressing the space bar will also move the page down 
one page at a time. If you press Shift and the Space bar the 
page will go up a page at a time. 

Tip: If you are using the space bar to go down one page at a time press the 

Shift key and space bar to go up one page at a time. 

Get rid of duplicate photos in Picasa 

Picasa will automatically look for duplicates when the program imports 
photos. 

Make sure this feature is turned on by going to Tools, Options, then clicking 
the General tab and making sure ‘Detect duplicates while importing' is ticked. 

The software also has an experimental feature designed to identify duplicate 
images in albums. 

Go to Tools, Experimental and select Show Duplicate Files. Get rid of any 

repeat images by selecting them and hitting Delete. 

Shutting Down Windows 8 

To shut Windows 8 down, jjust hold down the Windows key and press I 
You'll see a power button. Click this and choose 'Shut Down' or 'Restart'. 

Some of the tricks available in previous versions of Windows still apply. 

Press Ctrl+Alt+Del, for instance, click the power button in the bottom right-

hand corner and you'll be presented with the same 'Shut Down' and 'Restart' 

options. 

Turning off the Publisher Getting Started screen 

By default, when running Microsoft Publisher 2007 a "Getting Started with 
Microsoft Office Publisher 2007" screen appears. From this wizard you can 
select from a gallery of publication types including award certificates, 
greeting cards, and resumes; create blank pages in various sizes; open 
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Get the Quick Launch Toolbar Back in Windows 7 

Highlight and copy the following line of text: 

%userprofile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch 

Right-click the taskbar, choose Toolbars / New Toolbar 

Paste the copied text in the Folder box and then click Select Folder 

Right click on the Taskbar and turn off the “lock the taskbar” setting. Right-
click on the divider and make sure that “Show text” and “Show title” are 
disabled and the view is set to “small icons”. 

Use the dividers to rearrange the toolbar ordering to choice, and then lock 

the taskbar again. 

More keyboard shortcuts everyone should know 

Ctrl + Back space and Ctrl + Left or Right arrow 

Pressing Ctrl + Backspace will delete a full word at a time 
instead of a single character. 

Holding down the Ctrl key while pressing the left or right arrow 
will move the cursor one word at a time instead of one 
character at a time. If you wanted to highlight one word at a 
time you can hold down Ctrl + Shift and then press the left or 
right arrow key to move one word at a time in that direction 
while highlighting each word. 

Ctrl + S 

While working on a document or other file in almost every 
program pressing Ctrl + S will save that file. This shortcut key 
should be used frequently anytime you're working on anything 
important. 

Ctrl + Home or Ctrl + End 

Move the cursor to the beginning or end of a document. 

Ctrl + P 
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Laptop Quick Shutdown Option 

When you have finished working on your laptop it is possible to 
have it close windows and turn off simply by closing the lid. 
Here’s how: 

Click the Start button and immediately type power options 
A list of items appears above; click the one that offers ‘Change what the 
power buttons do’  

In the ‘When I close the lid’ area change the ‘On battery’ and/or ‘Plugged in’ 
options to ‘Shut down’ 

Click ‘Save changes’ 

Now you can simply close the lid when you are finished, Windows will close 

any open programs down and then it will close Windows and shut itself down 

When you do this the usual shutdown sounds will be heard as the laptop 

closes down. 
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Making an Image Stay in Place in Microsoft Word 
2010 

Typically, when you insert a picture into a Microsoft Word 2010 document, 
the image is inserted before or after text. If you add or remove text and the 
text around the image gets moved up or pushed down, then the image will 
also move. Sometimes, however, you may want the image to stay where you 
put it, or in an exact location within the document. 

To make the image stay in an absolute position, select the image and go to 
the Format tab on the ribbon at the top of the screen. Click the “Wrap Text” 
button and choose “More Layout Options” and then choose any option 
besides “In Line with Text”. Next, click the “Positioning” tab and choose 
“Absolute Positioning”. From there you can select the options that best suit 
your needs, either based on the page, columns, margins or characters, and 
click ok. 

The image should now stay put and the text should reflow as it is added or 

removed. 

Take a Virtual Vacation with Google Maps Street 
View Collections 

Looking for a way to “get away” but don’t have the time or money to go right 
now? Try taking a virtual vacation and seeing faraway lands by visiting the 
Google Maps Street View Collections at: maps.google.com/streetview 

Once you are at the site click the link to go to the gallery and then choose 
your destination from the list of collections. You can view street level images 
from places like, the Amazon, Swiss Alps, Italy, Hawaii, Thailand and Poland. 
You can also view collections that include images from university campuses, 
world landmarks, U.S. highlights, art galleries and much more! Once you 
have selected your destination you can move through the different locations, 
take 360 degree tours and even zoom in and out on specific areas. In some 
of the collections, you can even travel from room to room exploring art work 
and other features. 

Overall, a very interesting site to take a look at when you need a little escape 

from the everyday! 
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Instant Explorer window: 

Want to open a new Windows Explorer window without leaving the 
keyboard? Press Windows-E. 

Instant Desktop: 

Access your desktop instantly by pressing Windows-D to hide all open 

windows. Press Windows-D again to return to where you were. 

 

Use Hidden International Wallpapers and Themes 

When Windows 7 is installed it has many background scenery and themes 
from other English-speaking countries including Australia, Canada, Great 
Britain South Africa and more. 

Normally, you can't access those backgrounds or themes, but there is a 
simple way you can install and use them: 

1. In the search box in the Start menu, type C:\Windows\Globalization\MCT 
and press Enter. 

2. Windows Explorer will launch and show you a list of subfolders MCT-AU, 
MCT-CA, MCT-GB, MCT-US, and MCT-ZA. Each subfolder has wallpapers 
for a specific country: AU for Australia, CA for Canada, GB for Great Britain, 
US for the United States, and ZA for South Africa. For any of the countries 
whose wallpaper and themes you want to use, go into its Theme folder, for 
example, C:\Windows\Globalization\MCT\MCT-ZA\Theme. Double-click the 
theme you see there (for example ZA) 

3. That will install a shortcut to the theme and wallpapers in the 

Personalization section of Control Panel. You can now use them as you 

would any other theme or background, by right-clicking the desktop, 

choosing Personalize, and choosing a background or theme. They will be 

listed in their own section. 

file:///D:/My%20Web%20Sites/cvScc%20web/maps.google.com/streetview

